首页 > 股票公式 > 通达信波浪理论主图指标

通达信波浪理论主图指标

资料语言:简体中文

下载次数:

资料类别:股票公式

资料大小:3.77 KB

更新时间:2019-11-14 10:54:18

相关内容:波浪理论公式 波浪理论

  • 软件介绍

  • 网友评论
  • 下载地址

给大家分享一个刚找到的通达信版本的波浪理论指标,讲指标之前,先给大家普及下波浪理论的相关知识,让大家对于波浪理论有更加清楚的了解。


波浪理论 简介:


波浪理论是证券技术分析的主要理论之一,由艾略特(Ralph Nelson Elliott)提出。一些交易员用以分析金融市场周期,预测市场趋势。拉尔夫·纳尔逊·艾略特(1871-1948),专业会计师,于1930年提出分析方法,认为市场价格的走势具有特定的形态。1938年,艾略特发表《波浪理论》,正式提出此理论,并在1946年,他最后的主要著作《自然法则:宇宙的秘密》中进行了最为详细的阐述。艾略特写道“人受制于规律过程,关于人的活动的计算能被投射到未来的某个阶段,这一点我确信无疑”。波浪理论的实证有效性仍然充满争议。


波浪理论 结构:


一个完整的浪型是由驱动浪与调整浪构成,驱动浪一般情况是由5个子浪构成,调整浪一般由3个子浪构成。

波浪1

股票首次出现上涨。 通常的情况是因为一小波人认为该支股票的价格很便宜,适合买入,并确实在很短的时间内买了一部分该股票,进而导致了价格上涨。

波浪2

原来已经持有该支股票的一部分人认为股票价格过高,获利了结,进而导致了股票价格的下跌。但该支股票并没有触及到波浪1的最低点。

波浪3

这通常是最强也是最长的一波。该支股票吸引了公众的目光,更多的人发现该支股票具有潜力,并开始买入,这导致了股票价格的持续攀升。这一波的高点突破了波浪1的最高点。

波浪4

一部分人认为股票价格过高,开始获利了结。这一波通常不会太强,因为还有更多的人看好该支股票的涨势。

波浪5

波浪5通常是市场上绝大多数人关注该支股票的时刻,而且通常较不理性。人们可能会看到该公司的CEO登上各种主要杂志的封面,成为年度人物。人们开始以各种奇怪的理由买入该支股票,并对他人的劝解充耳不闻,进而使得股票价格被严重高估。

波浪A

A浪是下跌的开始,但投资者大多认为上升行情尚未逆转,仅为一个暂时的回档现象。实际上,A浪的下跌在第5浪中通常已有警告讯号,如成交量与价格走势背离或技术指标背离,但由于此时市场仍较为乐观,A浪有时出现平台调整。

波浪B

B浪是对A浪的反弹,但是成交量不大。一般而言是多头的逃命线,但由于大多数投资者误以为是另一波段的涨势,因而B浪常形成“多头陷阱”,投资者在此惨遭套牢。B浪在技术上很少是强劲的,在B浪中活跃的股票数量有限,但绩优股却十分抗跌。

波浪C

C浪是一段破坏力较强的下跌浪,跌势较为强劲,跌幅大,持续的时间较久,而且出现全面性下跌。


波浪理论 形态图


波浪理论形态图.png


波浪理论 指标截图


波浪理论指标主图.png


波浪理论指标主图.png


波浪理论 公式源码


V1:=MA(HIGH,30)*1.15;

V2:=MA(HIGH,3)*1.03;

V3:=MA(LOW,3)*0.97;

V4:=MA(LOW,30)*0.85;

DRAWTEXT_FIX(1,0.00,0.00,0,'小白公式提供,更多公式登陆 157110.COM 下载'),COLORRED;

GET:ZIG(3,N),COLORYELLOW;

PL5:=ZIG(3,5);

EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);

EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);

PL10:=ZIG(3,10);

EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);

EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);

PL20:=ZIG(3,20);

EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);

EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);

PL40:=ZIG(3,40);

走强1:=BARSLAST(PL5<REF(PL5,1));

走弱1:=BARSLAST(PL5>REF(PL5,1));

走强2:=BARSLAST(PL10<REF(PL10,1));

走弱2:=BARSLAST(PL10>REF(PL10,1));

走强3:=BARSLAST(PL20<REF(PL20,1));

走弱3:=BARSLAST(PL20>REF(PL20,1));

ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);

ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);

DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);

DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);

ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);

ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);

DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);

DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);

DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'㈠'),COLORFFFF00;

DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'㈡'),COLORFFFF00;

DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,'㈢'),COLORFFFF00;

DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.02,'⑴'),COLOR0000FF;

DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,'⑵'),COLOR0000FF;

DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,'⑶'),COLOR0000FF;

DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,'⑷'),COLOR0000FF;

DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.02,'⑸'),COLOR0000FF;

DRAWTEXT(EN2 AND DTJZ10=1,L*0.94,'Ⅰ'),COLORFF6000;

DRAWTEXT(EX2 AND DTJD10=2,H*1.06,'Ⅱ'),COLORFF6000;

DRAWTEXT(EN3 AND ZTJZ10=1,L*0.94,'Ⅲ'),COLORFF6000;

DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.06,'①'),LINETHICK3,COLOR00FFFF;

DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.94,'②'),LINETHICK3,COLOR00FFFF;

DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.06,'③'),LINETHICK3,COLOR00FFFF;

DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.94,'④'),LINETHICK3,COLOR00FFFF;


  • 通达信波浪理论主图指标  下载地址

  • 热门标签