首页 > 股票公式 > 新股民必备买卖主图

新股民必备买卖主图

资料语言:简体中文

下载次数:

资料类别:股票公式

资料大小:7.17 KB

更新时间:2019-11-09 08:08:07

相关内容:

  • 软件介绍

  • 网友评论
  • 下载地址

买卖主图公式简介:


做股票应不要太在乎一天的得失,关键能否长久达到稳键复利,今天给大家放出一款实战精品买卖主图指标,适用于通达信版本,经小白亲测,没有带未来函数,可以提示操盘策略,BS买卖点,支撑阻力位等,对于新股民散户来说,绝对有用,此指标适用于所有周期,不同级别,不管是日线、周线、还是30分钟,60分钟,甚至是1分钟都适用。做长线、做中线还是做短线全部都可以。


买卖主图公式截图:


买卖主图公式.png


买卖主图公式.png


买卖主图公式.png



买卖主图公式源码:


MA5:MA(CLOSE,5);

MID:=(3*C+L+O+H)/6;

牛线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)

+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)

+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)

+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)

+2*REF(MID,18)+REF(MID,20))/210,COLORRED;

马线:MA(牛线,6),COLORGREEN;

VAR0:=SMA(MAX(C-REF(C,1),0),12,1)/SMA(ABS(C-REF(C,1)),15,1)*100;

DRAWTEXT(CROSS(82,VAR0),H,'快卖'),COLORWHITE;

A:=HHV(H,13)=H AND H>REF(H,1);A1:=FILTER(A,12);

B:=LLV(L,13)=L AND L<REF(L,1);B1:=FILTER(B,12);TS1:=BARSLAST(A1);

箱顶:REF(H,TS1),COLORFF00FF,NODRAW;  

STICKLINE(1,箱顶,箱顶,1,0),COLORFF00FF;TS2:=BARSLAST(B1);

箱底:REF(L,TS2),COLORFFBB80,NODRAW;STICKLINE(1,箱底,箱底,1,0),COLORFFBB80;

箱高:100*(箱顶-箱底)/箱底,COLORFFFF00,NODRAW;均价:=(3*C+H+L+O)/6;

VAR1:=(8*均价+7*REF(均价,1)+6*REF(均价,2)+5*REF(均价,3)+

4*REF(均价,4)+3*REF(均价,5)+2*REF(均价,6)+REF(均价,8))/36;

VAR2:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;

SZ1:=REF(VAR1,1)=REF(VAR2,1) AND VAR1>VAR2 AND C>VAR1;

SZ2:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1)

AND H/VAR1<1.1 AND L>VAR2 AND C>VAR1;

SZ3:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>=REF(VAR2,1) AND H/VAR1>1.1;

SZ4:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1) AND C>VAR2 AND C<VAR1;

SZ5:=(VAR1>VAR2 AND VAR2>REF(VAR2,1) AND VAR1<>REF(VAR1,1)

AND C<VAR2) OR (VAR1>VAR2 AND VAR1<REF(VAR1,1) AND VAR2<REF(VAR2,1) AND C<VAR2);

SZ6:=REF(VAR1,1)>REF(VAR2,1) AND VAR1=VAR2 AND C<VAR2;

XD1:=VAR1=VAR2 AND C<VAR2 OR (VAR1<REF(VAR1,1) AND VAR2<REF(VAR2,1)

AND REF(VAR1,1)=REF(VAR2,1) AND C<VAR2);XD2:=VAR1=VAR2 AND C>VAR1;

STICKLINE(C>O,O,L,0,0 ),COLOR0000FF;STICKLINE(C>O,C,H,0 ,0 ),COLOR0000FF;

STICKLINE(O>=C,C,L,0 ,0 ),COLOR00FF00;STICKLINE(O>=C,O,H,0 ,0 ),COLOR00FF00;

STICKLINE(O>=C ,C ,O,3.1,0 ),COLORFF7700;STICKLINE(O>=C ,C ,O,2.5,0 ),COLORFF9900;

STICKLINE(O>=C ,C ,O,2,0 ),COLORFFBB00;STICKLINE(O>=C ,C ,O,1.5,0 ),COLORFFCC00;

STICKLINE(O>=C ,C ,O,1,0 ),COLORFFDD00;STICKLINE(O>=C ,C ,O,0.5,0 ),COLORFFEE00;

STICKLINE(O>=C ,C ,O,0.1,0 ),COLORFFFF00;STICKLINE(C>O,C,O,3.1,0) ,COLOR000055;

STICKLINE(C>O,C,O,2.5,0) ,COLOR000066;STICKLINE(C>O,C,O,2,0) ,COLOR000077;

STICKLINE(C>O,C,O,1.5,0) ,COLOR000099;STICKLINE(C>O,C,O,1,0) ,COLOR0000BB;

STICKLINE(C>O,C,O,0.5,0) ,COLOR0000DD;STICKLINE(C>O,C,O,0.1,0) ,COLOR0000FF;

VAR9Q:=C= HHV(C,4)AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3))

OR REF(C,1)=HHV(C,4) AND C>=REF(C,2) OR REF(C,2)=HHV(C,4) AND REF(C,3)=LLV(C,4) 

AND C>=REF(C,1) OR REF(C,3)=HHV(C,4)AND C>=REF(C,1) AND C>=REF(C,2);

STICKLINE(VAR9Q,C,(O+C)/2,3.1,0),COLOR000055;

STICKLINE(VAR9Q,C,(O+C)/2,2.5,0),COLOR000066;

STICKLINE(VAR9Q,C,(O+C)/2,2,0),COLOR000077;

STICKLINE(VAR9Q,C,(O+C)/2,1.5,0),COLOR000099;

STICKLINE(VAR9Q,C,(O+C)/2,1,0),COLOR0000BB;

STICKLINE(VAR9Q,C,(O+C)/2,0.5,0),COLOR0000DD;

STICKLINE(VAR9Q,C,(O+C)/2,0.1,0),COLOR0000FF;

VARAQ:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);

STICKLINE(VARAQ,C,(O+C)/2,3.1,0),COLORFF11FF;

STICKLINE(VARAQ,C,(O+C)/2,2.5,0),COLORFF33FF;

STICKLINE(VARAQ,C,(O+C)/2,2,0),COLORFF55FF;

STICKLINE(VARAQ,C,(O+C)/2,1.5,0),COLORFF77FF;

STICKLINE(VARAQ,C,(O+C)/2,1,0),COLORFF99FF;

STICKLINE(VARAQ,C,(O+C)/2,0.5,0),COLORFFBBFF;

STICKLINE(VARAQ,C,(O+C)/2,0.1,0),COLORFFDDFF;

VARBQ:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) 

AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<>HHV(C,4) AND C<REF(C,1) 

OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);

STICKLINE(VARBQ,C,(O+C)/2,3.1,0),COLOR333333;

STICKLINE(VARBQ,C,(O+C)/2,2.5,0),COLOR555555;

STICKLINE(VARBQ,C,(O+C)/2,2,0),COLOR777777;

STICKLINE(VARBQ,C,(O+C)/2,1.5,0),COLOR999999;

STICKLINE(VARBQ,C,(O+C)/2,1,0),COLORBBBBBB;

STICKLINE(VARBQ,C,(O+C)/2,0.5,0),COLORDDDDDD;

STICKLINE(VARBQ,C,(O+C)/2,0.11,0),COLORFFFFFF;

VARCQ:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4)

AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);

STICKLINE(VARCQ,O,(O+C)/2,3.1,0),COLOR00AAFF; 

S:=C-REF(C,1);DX:=100*EMA(EMA(S,6),6)/EMA(EMA(ABS(S),6),6);

买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);

DRAWTEXT(FILTER(买=1,5),L-0.03,'拉升'),COLORFFDE00;

DA:=(EMA(C,1)+EMA(C,2)+EMA(C,3)+EMA(C,4))/4;

DB:=(EMA(C,10)+EMA(C,20)+EMA(C,40)+EMA(C,80))/4;

DRAWTEXT(CROSS(DA-DB,0),L*0.95,'★B'),COLORRED;

JH:=SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100;

DRAWTEXT(CROSS(84,JH),H*1.05,'☆S'),COLORGREEN;

YC:=REF(C,1);止损价位:(YC*1.0035*97+0.2)/99.65,COLORRED,NODRAW;

GNFG:=STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(CODE,'  '),STKNAME),'   '),GNBLOCK),' '),FGBLOCK);

DRAWTEXT_FIX(ISLASTBAR,0.01,0.013,0,GNFG),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.01,0.06,0,'★ ================='),COLORRED;

DRAWTEXT_FIX(ISLASTBAR,0.01,0.1,0,'操 '),COLORRED;

DRAWTEXT_FIX(ISLASTBAR,0.01,0.14,0,'盘 '),COLORRED;

DRAWTEXT_FIX(ISLASTBAR,0.01,0.18,0,'铁'),COLORRED;

DRAWTEXT_FIX(ISLASTBAR,0.01,0.22,0,'律'),COLORRED;

DRAWTEXT_FIX(ISLASTBAR,0.01,0.26,0,'★ =================='),COLORRED;

DRAWTEXT_FIX(ISLASTBAR,0.02,0.09,0,'   买入条件    E13 CCI'),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.02,0.135,0,'   买入时间    2:30以后'  ),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.02,0.18,0,STRCAT('   止损价位    ',STRCAT(CON2STR(止损价位,2),'元'))),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.02,0.23,0,'   线上:工作   线下:休息'),COLOR00FFFF;

E:=(H+L+O+2*C)/5;明日阻力:=2*E-L;明日支撑:=2*E-H;明日突破:=E+(H-L);

明日反转:=E-(H-L);今日阻力:=REF(明日阻力,1);今日支撑:=REF(明日支撑,1);

DRAWTEXT_FIX(ISLASTBAR,0.17,0.06,0,STRCAT('今日阻力=',CON2STR(今日阻力,2))),COLORFFFF00;

DRAWTEXT_FIX(ISLASTBAR,0.17,0.1,0,STRCAT('今日支撑=',CON2STR(今日支撑,2))),COLORRED;

DRAWTEXT_FIX(ISLASTBAR,0.17,0.14,0,STRCAT('明日突破=',CON2STR(明日突破,2))),COLORFF00FF;

DRAWTEXT_FIX(ISLASTBAR,0.17,0.18,0,STRCAT('明日阻力=',CON2STR(明日阻力,2))),COLORFFFF00;

DRAWTEXT_FIX(ISLASTBAR,0.17,0.22,0,STRCAT('明日支撑=',CON2STR(明日支撑,2))),COLORRED;

DRAWTEXT_FIX(ISLASTBAR,0.17,0.26,0,STRCAT('明日反转=',CON2STR(明日反转,2))),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR AND SZ1,0.3,0.06,0,'调整结束短线介入'),COLORRED;

DRAWTEXT_FIX(ISLASTBAR AND SZ2,0.3,0.06,0,'上升通道走势良好'),COLORRED;

DRAWTEXT_FIX(ISLASTBAR AND SZ3,0.3,0.06,0,'股价偏离注意调整'),COLORRED;

DRAWTEXT_FIX(ISLASTBAR AND SZ4,0.3,0.06,0,'上升通道调整洗盘'),COLORGREEN;

DRAWTEXT_FIX(ISLASTBAR AND SZ5,0.3,0.06,0,'转向特征注意离场'),COLORGREEN;

DRAWTEXT_FIX(ISLASTBAR AND SZ6,0.3,0.06,0,'通道改变坚决离场'),COLORGREEN;

DRAWTEXT_FIX(ISLASTBAR AND XD1 AND NOT(SZ6),0.3,0.06,0,'下跌通道只宜观望'),COLORGREEN;

DRAWTEXT_FIX(ISLASTBAR AND XD2,0.3,0.06,0,'短期底部准备进入'),COLORYELLOW;


相关资料
  • 新股民必备买卖主图  下载地址

猜你喜欢
  • 热门标签